HEMS Moodle Site Upgrade Summary

 
Picture of Peter Keogan
HEMS Moodle Site Upgrade Summary
by Peter Keogan - Saturday, July 22, 2017, 7:48 AM
 

The HEMS Moodle site has been upgraded from 2.9 to 3.3. This upgrade is quite a significant leep into the future, for both the performance and functionality. The version of Moodle we were running previously was Moodle 2.9, which was released in 2014. Moodle 2.9 was running on a outdated software platform (PHP 5.4), which has been labeled "End of Life" since 2015. End of Life is a software release that is no longer supported. Software that is at its End of Life status is exposed to unpatched security vulnerabilities and performance issues. 

Moodle 3.3 is the most up to date stable version of Moodle. Moodle 3.3 has the ability to run on the newest software platform PHP7.1. This newest software upgrade has performance increases up to 259%. It is important to note, that this performance increase will not directly reflect onto the site, but overall will show large improvements. There are also many new features within Moodle that have been added to its core repository. During the development of this site I plan on adding these features and teaching instructors how to implement them into their courses. 

In summary, this upgrade of both Moodle and the software platforms it runs on, will give every user of this site a more responsive, faster and secure experience. This site will have many features added into it over the next coming months, which in turn will give every user here a better experience.

If you have any questions, comments, or concerns regarding this update/upgrade, please email Peter Keogan or David Rogers. (Peter.Keogan@hcmed.org or David.Rogers@hcmed.org)